[Tiptoi] Text-to-speech

Joachim Breitner mail at joachim-breitner.de
Do Jan 22 00:05:48 CET 2015


Hi,

Am Mittwoch, den 21.01.2015, 23:38 +0100 schrieb Ulrich Sibiller:
> uli at traube:~/work/tiptoi/tip-toi-reveng$ cabal update
> Downloading the latest package list from hackage.haskell.org
> uli at traube:~/work/tiptoi/tip-toi-reveng$ cabal install --dependencies-only
> cabal: unrecognized option `--dependencies-only'

hmm. Maybe that was added in a newer version. What does "cabal
--version" say?

> I cleanup up using ghc-pkg unregister and removed my ~/.cabal dir and
> now I get this:
> uli at traube:~/work/tiptoi/tip-toi-reveng$ cabal install --bindir=`pwd`
> Resolving dependencies...
> cabal: Could not resolve dependencies:
> trying: tttool-0.1
> rejecting: base-4.7.0.2, 4.7.0.1, 4.7.0.0, 4.6.0.1, 4.6.0.0, 4.5.1.0, 4.5.0.0
> (only already installed instances can be used)
> rejecting: base-4.4.1.0, 4.4.0.0, 4.3.1.0, 4.3.0.0, 4.2.0.2, 4.2.0.1, 4.2.0.0,
> 4.1.0.0, 4.0.0.0, 3.0.3.2, 3.0.3.1 (conflict: tttool => base==4.5.* || ==4.6.*
> || ==4.7.* || ==4.8.*)
> 
> So what can I do to make this run again?

Do you really have ghc installed from 14.04? According to
http://packages.ubuntu.com/search?keywords=ghc this should be ghc-7.6.3,
which is the same version I’m using, and which comes with base 4.6.

It looks like you have some very old version of ghc (and cabal) lying
around.

Greetings,
Joachim


-- 
Joachim “nomeata” Breitner
  mail at joachim-breitner.dehttp://www.joachim-breitner.de/
  Jabber: nomeata at joachim-breitner.de  • GPG-Key: 0xF0FBF51F
  Debian Developer: nomeata at debian.org

-------------- nächster Teil --------------
Ein Dateianhang mit Binärdaten wurde abgetrennt...
Dateiname   : signature.asc
Dateityp    : application/pgp-signature
Dateigröße  : 819 bytes
Beschreibung: This is a digitally signed message part
URL         : <https://lists.nomeata.de/archive/tiptoi/attachments/20150122/330fd35d/attachment.sig>


Mehr Informationen über die Mailingliste tiptoi